NOV is investigating an issue that is casuing some of their WITSML streams to go on delay which is causing some of the wells in Corva to be on delay

Incident Report for Corva

Resolved

This incident has been resolved.
Posted Mar 10, 2026 - 22:50 CDT

Investigating

Some assets may be on delay as a result of an issue with NOV WITSML streams going on delay. NOV is currently investigating the issue
Posted Mar 10, 2026 - 22:36 CDT