Completions data delay

Incident Report for Corva

Resolved

This incident has been resolved.
Posted May 02, 2025 - 19:37 CDT

Update

Completions apps and dashboards on delay
Posted May 02, 2025 - 19:36 CDT

Investigating

We are currently investigating the cause of the issue.
Posted May 02, 2025 - 19:33 CDT
This incident affected: Web and API.